Degraded Portal Networking
Incident Report for Giggl
Resolved
This incident has been resolved.
Posted Aug 23, 2021 - 21:02 UTC
Investigating
We are currently investigating this issue.
Posted Aug 23, 2021 - 20:55 UTC
This incident affected: Portals Service.