Issues connecting to US-East portals
Incident Report for Giggl
Resolved
This incident has been resolved.
Posted Apr 08, 2022 - 07:25 UTC
Investigating
We are currently investigating this issue.
Posted Apr 08, 2022 - 06:28 UTC
This incident affected: Portal & RTC Regions (US East).