Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 17, 2021 - 17:30 UTC
Scheduled
On Sunday, we will be performing some core infrastructure & server upgrades which will optimize and make your Giggl experience a lot better. We expect this to take an hour at most.
Posted Oct 16, 2021 - 02:19 UTC
This scheduled maintenance affected: Portals Service, Orbit, Web and Portal & RTC Regions (US East).