Sites Loading Slowly in Portals
Incident Report for Giggl
Resolved
This incident has been resolved.
Posted Oct 07, 2021 - 02:20 UTC
Investigating
We're aware that some websites may take longer than usual to load within Giggl portals. We're currently investigating these issues.
Posted Oct 05, 2021 - 00:37 UTC
This incident affected: Portals Service.