Degraded Portal Networking
Incident Report for Giggl
Resolved
This incident has been resolved.
Posted Jun 09, 2021 - 19:27 UTC
Investigating
You may notice intermittent lag spikes while watching videos on Giggl.
Posted Jun 09, 2021 - 18:03 UTC
This incident affected: Portal & RTC Regions (US East) and Portals Service.