Packet Loss from Downstream ISP: Virgin Media
Incident Report for Giggl
Resolved
We believe this issue has stabilized as we are no longer seeing excessive packet loss from Virgin Media.
Posted Aug 31, 2021 - 22:59 UTC
Monitoring
If your ISP is Virgin Media, you may notice intermittent lag spikes or elevated latency when using Giggl. We're in contact with their team to try and resolve this ASAP.
Posted Aug 31, 2021 - 22:42 UTC
This incident affected: Portal & RTC Regions (EU West (UK)).