Portal Creation Issues & Inconsistencies
Incident Report for Giggl
Resolved
This incident has been resolved.
Posted Jul 07, 2021 - 00:27 UTC
Investigating
We are currently investigating this issue.
Posted Jul 07, 2021 - 00:06 UTC
This incident affected: Portals Service.