Issues Loading Discovery Page
Incident Report for Giggl
Resolved
This incident has been resolved.
Posted Jun 24, 2021 - 02:42 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 24, 2021 - 02:40 UTC
This incident affected: API.