Portal Creation Issues
Incident Report for Giggl
Resolved
This incident has been resolved.
Posted Jul 05, 2021 - 00:09 UTC
Investigating
We are currently investigating this issue.
Posted Jul 05, 2021 - 00:04 UTC
This incident affected: Portals Service.