US East Instability
Incident Report for Giggl
Resolved
This incident has been resolved.
Posted Apr 27, 2022 - 22:11 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 27, 2022 - 20:40 UTC
Investigating
We are currently investigating this issue.
Posted Apr 27, 2022 - 20:23 UTC
This incident affected: Portal & RTC Regions (US East).