Limited Availability
Incident Report for Giggl
Resolved
This incident has been resolved.
Posted Nov 21, 2021 - 05:30 UTC
Identified
We have identified an issue which has halved our portal availability. You may experience queues and slowness platform-wide while we rectify the issue.
Posted Nov 21, 2021 - 04:41 UTC
This incident affected: Portals Service.